The mcrypt PHP extension is required by Yii2.

Ok,

volviendo a las canchas de desarrollo nuevamente uso Yii pero la nueva versión, muy originalmente llamada Yii2.

No voy a explicar la instalación solo un error que me pasó para que no le pase a alguien más.

La librería MCrypt es una librería que le permite al desarrollador utilizar muchos algoritmos de encriptación de manera transparente solo invocando su función.  Yii2 ha mejorado mucho en seguridad por lo que es un requerimiento.

Si te topas con este error simplemente instalaremos la librería ( en mi caso en Ubuntu Server ) y la activaremos en el apache2.

sudo apt-get install mcrypt php5-mcrypt
sudo php5enmod mcrypt
sudo /etc/init.d/apache2 restart

Esto debería eliminar cualquier problema que tengamos en el momento de la instalación con composer de Yii o en su ejecución si fue instalado de manera estándar.

Deja un comentario

This site uses Akismet to reduce spam. Learn how your comment data is processed.